API version '4' for vCenter Server '<vCenterName>' is not supported.

Summary:
This helpful message appears when you attempt to use a VUM 4.1 PowerCLI cmdlet against a 4.0 vCenter / Update Manager version.
Resolution:
Uninstall VUM 4.1 PowerCLI and install VUM 4.0U1 PowerCLI.
Takeaway:
Read the release notes and hope that VMWare has right download link posted on their site, which as of this posting is wrong.  The link posted above is correct.
vmwaresite

No comments: